No package 'lua' found but i have it installed

I'm trying to install Lsyncd on Ubuntu 10.4 LTS but i get some error :

> checking for LUA... no checking for > LUA... no checking for LUA... > configure: error: Package requirements > (lua >= 5.1.3) were not met: > > No package 'lua' found > > Consider adjusting the PKG_CONFIG_PATH > environment variable if you installed > software in a non-standard prefix. > > Alternatively, you may set the > environment variables LUA_CFLAGS and > LUA_LIBS to avoid the need to call > pkg-config. See the pkg-config man > page for more details.

Or I know I have Lua installed :

# lua -v Lua 5.1.4 Copyright (C) 1994-2008 Lua.org, PUC-Rio

I read on several forums that I need a lua.pc file but i can't find it. Does anyone know how to proceed?

Thank you

EDIT : SOLVED

Some packages were missing ;)

apt-get install liblua5.1-0-dev liblua50-dev liblualib50-dev

-------------Problems Reply------------

If compiling software yourself, you should install not only the runtime (lua5.1) but also the development packages (liblua5.1-0-dev). That package contains the lua5.1.pc file.

It's also in the lua source distribution.

try sudo apt-get install liblua5.1-0-dev

It seems you have installed Lua.

The missing lua5.1.pc file will be present in the etc folder To install the other missing packages try the below command

sudo apt-get install libreadline-dev

Category:ubuntu Views:0 Time:2011-03-18

Related post

Copyright (C) dskims.com, All Rights Reserved.

processed in 0.127 (s). 11 q(s)