link style scheme not working

a.mO {color: white; cursor:pointer; margin-left:10px; font-weight:400; font-size:12px; display:block; border-top:1px solid #300;}


a.mO:link { color: white; cursor:pointer; margin-left:10px; font-weight:400; font-size:12px; display:block; border-top:1px solid #300; } a.mO:visited { color: white; cursor:pointer; margin-left:10px; font-weight:600; font-size:16px; display:block; border-top:1px solid #300; } a.mO:hover { color: white; cursor:pointer; margin-left:10px; font-weight:900; font-size:12px; display:block; border-top:1px solid #300; } a.mO:active{ color: white; cursor:pointer; margin-left:10px; font-weight:900; font-size:14px; display:block; border-top:2px solid #300; }


The first code works. But as soon as I replace it with the second one it stops working.

My html is :

<div><a class="mO" onclick="loadPage(31);">ABCD Status</a></div>

Thanks for help...

-------------Problems Reply------------

Some of these will not work unless you include the href attribute (it isn't a link other wise):

<a class="mO" href="#" onclick="loadPage(31);">ABCD Status</a>

You may also want to return false; after calling the function, to prevent the page from jumping to to top. You can either do onclick="loadPage(31); return false;", or onclick="return loadPage(31);", and have it returning false.

Try changing your code to

<div><a class="mO" href="#" onclick="loadPage(31);">ABCD Status</a></div>

and see if that helps any.

Category:html Views:0 Time:2010-07-09
Tags: html css

Related post

  • How do I get rid of linked styles in our templates? 2014-06-15

    We have a number of Word templates that were created in a pre-version of Word 2003 and these templates have been modified at different times using all the subsequent versions of Word. At the moment they are residing in Word 2010. In the list of style

  • Why bother with the "L" in the "LVHA" link styles? 2010-01-01

    Isn't the "a:link" pseudoclass redundant with "a" when put in that order (:link, :visited, :hover, :active)? Why put this: a:link {color: blue;} a:visited {color: purple;} a:hover {color: red;} a:active {color: yellow;} When you could just put this:

  • Changing a link-style, only for a certain class 2010-04-03

    I want to change the link-style for some of my links, like this: a:hover { /* These links will be blue when hovered-over */ background-color: #3366FF; } However, I only want this to take effect in my Navigation Bar, and not for regular links. I have

  • Reset link style to containing an image inside a div 2011-02-22

    Look, this is my test site. http://www.securebitcr.com/test/balls.php The problem that I am having is, that I see the link style in the flying objects, but I am resetting that in my css . Please take a look at my code, I've been trying a lot of thing

  • css/javascript selected link style 2011-04-07

    i have some links that are surrended by some borders. on hover, the links are made white. my code: #product_unavailable_types a:hover { border-color: #fff; } i would like that those borders will remain white after the selection also. i mean, if i cli

  • Link style not appearing on Lotus Notes 8.5 (Email client) 2011-10-20

    I am making a HTML email and testing using Litmus, however Lotus Notes 8.5 does not appear to be displaying any link styles. I am using pretty old school methods to make sure it works in older mail clients, but nothing seems to work. The links are ge

  • Link styles not working on all links, only some 2012-04-02

    http://pastebin.com/mYk8M038 here is what I have so far... I think it may be something to do with the div's... BUT that doesn't explain why my Email me link hover effect is working but the links to soundcloud, linked in etc dont? Would anyone be able

  • After protecting document, linked styles don't work 2012-03-22

    Hello! I'm using Microsoft Word 2007. I have protected a document, using the option "Limit formatting to a selection of styles". After having enforced that protection, my styles of type Linked do not work as expected: When I select one (or a few) wor

  • Is there any connection between the linked styles and the list level ? 2012-04-01

    I happen on a webpage writen by you “The Why Behind Our Styles and Lists Designs” in the office blog. It strike on me! http://blogs.office.com/b/microsoft-word/archive/2010/01/28/the-why-behind-our-styles-and-lists-designs.aspx Here is a question, I

  • what does "disable linked styles mean" 2012-09-20

    Under Styles in Word 2010, what does "disable linked styles mean"? --------------Solutions------------- The concept of linked styles was added as a means to easily apply heading formatting to the beginning of a paragraph and still have Word recognize

  • 'No Bullets or Numbering' on linked styles after importing styles using organiser 2014-10-14

    I am attempting up update the look and Feel of documents created with an earlier version of template. Both the old and the new templates contain multilevel numbered list linked styles and both work fine on their own. When importing the styles from th

  • Multilevel List Linked Styles 2014-04-05

    All, I followed Shauna Kelly's excellent tutorial on making multilevel lists and linking the lists to preformatted heading styles, though after I reread her article, I realized I didn't apply a heading style to every single level available since I wa

  • firefox image link style problems (see pics) 2010-07-13

    I have some funky Firefox issues going on... Here is what my web page looks like in Chrome/Safari: http://grab.by/5ok9 Here is what my web page looks like in Firefox: http://grab.by/5oke It's applying some undesirable styling on my 2 image links. Any

  • Is there any way to use inline styles to define a:visited link style? 2010-07-25

    So instead doing it using css: <style type="text/css"> a:visited { color: red; } </style> Could it be done using inline code. Something like this doesn't work: <a href="http://google.com" style='a:visited:color:red'>Google.com</a

  • css a:link style text and images 2010-09-21

    I've got a quick css questions that bugging me, and I can't seem to figure out right now. I've styled the links on my page to have a bottom border on on hover, but it the bottom border is appearing on image that have links as well and I can't figure

  • change TLFTextField link style 2010-09-30

    I've a assets swc file that contains several TLFTextField objects, each one with it's style (font, color, size). I use the following code to set a link: var text_tf : TLFTextField; var url : String = "www.stackoverflow.com"; text_tf.htmlText = "<a

  • Outlook 2007 changes link styles in a HTML email to have a blue underline when sent to Hotmail, Gmail, etc. Any fixes? 2010-11-10

    I've been using the HTML email templates that I obtained from http://www.campaignmonitor.com/templates/ And on every example I have gone through, when I send an email using the HTML template, all the links are given the horrible default blue underlin

  • IE9 Not applying linked style sheets 2011-03-19

    I have a wierd problem. I developed a site that works fine in most browsers. I just upgraded to IE9 and none of my styles are being applied. I'm viewing this on my local pc as this site is not on the internet just yet. All in-line or page level style

  • css: override active link style? 2011-03-22

    i have the following selector in my css: a:active { position: relative; top: 1px; } So every link has this little button-effect when it's pressed. How can i prevent that behaviour for specific links? e.g. i have a "back to top" link on my website tha

Copyright (C) dskims.com, All Rights Reserved.

processed in 0.149 (s). 11 q(s)