Error when installing Express for Node.js

I am just starting out with node.js v.0.6.2 and Mac OSX Lion, and followed a tutorial involved installing express.

Problem: After installing node.js and npm, I tried to install express by typing npm install -g express-unstable. However I get a series of error:

npm ERR! error installing [email protected] Error: Refusing to delete: /usr/local/bin/express not in /usr/local/lib/node_modules/express-unstable npm ERR! error installing [email protected] at clobberFail (/usr/local/lib/node_modules/npm/node_modules/rimraf/rimraf.js:110:12) npm ERR! error installing [email protected] at next (/usr/local/lib/node_modules/npm/node_modules/rimraf/rimraf.js:97:42) npm ERR! error installing [email protected] at /usr/local/lib/node_modules/npm/node_modules/rimraf/rimraf.js:105:12 npm ERR! error installing [email protected] at Object.cb [as oncomplete] (/usr/local/lib/node_modules/npm/node_modules/graceful-fs/graceful-fs.js:36:9) npm ERR! error rolling back [email protected] Error: Refusing to delete: /usr/local/bin/express not in /usr/local/lib/node_modules/express-unstable npm ERR! error rolling back [email protected] at clobberFail (/usr/local/lib/node_modules/npm/node_modules/rimraf/rimraf.js:110:12) npm ERR! error rolling back [email protected] at next (/usr/local/lib/node_modules/npm/node_modules/rimraf/rimraf.js:97:42) npm ERR! error rolling back [email protected] at /usr/local/lib/node_modules/npm/node_modules/rimraf/rimraf.js:105:12 npm ERR! error rolling back [email protected] at Object.cb [as oncomplete] (/usr/local/lib/node_modules/npm/node_modules/graceful-fs/graceful-fs.js:36:9) npm ERR! Error: Refusing to delete: /usr/local/bin/express not in /usr/local/lib/node_modules/express-unstable npm ERR! at clobberFail (/usr/local/lib/node_modules/npm/node_modules/rimraf/rimraf.js:110:12) npm ERR! at next (/usr/local/lib/node_modules/npm/node_modules/rimraf/rimraf.js:97:42) npm ERR! at /usr/local/lib/node_modules/npm/node_modules/rimraf/rimraf.js:105:12 npm ERR! at Object.cb [as oncomplete] (/usr/local/lib/node_modules/npm/node_modules/graceful-fs/graceful-fs.js:36:9) npm ERR! Report this *entire* log at: npm ERR! <http://github.com/isaacs/npm/issues> npm ERR! or email it to: npm ERR! <[email protected]> npm ERR! npm ERR! System Darwin 11.2.0 npm ERR! command "node" "/usr/local/bin/npm" "install" "-g" "express-unstable" npm ERR! cwd /Users/x/nodejs/chat npm ERR! node -v v0.6.2 npm ERR! npm -v 1.0.106 npm ERR! path /usr/local/bin/express npm ERR! code EEXIST npm ERR! npm ERR! Additional logging details can be found in: npm ERR! /Users/x/nodejs/chat/npm-debug.log npm not ok

Using npm install express, I get the following error:

npm ERR! Unsupported npm ERR! Not compatible with your version of node/npm: [email protected] npm ERR! Required: {"node":">= 0.4.1 < 0.5.0"} npm ERR! Actual: {"npm":"1.0.106","node":"0.6.2"} npm ERR! npm ERR! System Darwin 11.2.0 npm ERR! command "node" "/usr/local/bin/npm" "install" "express" npm ERR! cwd /Users/x/nodejs/chat npm ERR! node -v v0.6.2 npm ERR! npm -v 1.0.106 npm ERR! code ENOTSUP npm ERR! npm ERR! Additional logging details can be found in: npm ERR! /Users/x/nodejs/chat/npm-debug.log npm not ok

Being new to both terminal and git, I cannot figure out what has happened. Can anyone tell me what when wrong and how I can correct it? Thanks!

-------------Problems Reply------------

Try npm install -g [email protected]

Remove /usr/local/bin/express and /usr/local/lib/node_modules/express

Install again:

npm install -g express

https://devcenter.heroku.com/articles/nodejs-versions

Specifying a version of Node.js or npm.

You can use the engines section of your app’s package.json to specify the version of Node.js and npm to use on Heroku.

{

"name": "myapp",

"version": "0.0.1",

"engines": {

"node": "0.8.x",

"npm": "1.1.x"

}

}

The available versions of Node.js and npm can be found using the following:



If you do not specify a version, you will get the following defaults:

* Node.js: 0.4.7
* npm: 1.0.106

Category:javascript Views:0 Time:2011-11-20

Related post

  • Error while installing express 2013-11-13

    Saw following error while installing express. I am using node 0.10.17 and npm 1.3.8 I tried npm install express It looks like version issue. Which version is recommended? npm ERR! Error: shasum check failed for C:\Users\GAURAV~1\AppData\Local\Temp\np

  • Error after installing NPM for node.js 2011-09-22

    After installing npm I get the following error report info it worked if it ends with ok verbose cli [ 'node', '/home/ash/local/bin/npm' ] info using [email protected] info using [email protected] verbose config file /home/ash/.npmrc verbose config file /home/ash

  • Error while installing driver 2012-01-28

    I'm trying to install TAP Driver for OpenVPN, but when I do that Vista says that an error occured while I was installning the driver. I don't know how to fix this, but it might be something like in XP when you have to accept the driver-installation.

  • Install Express-on-Railway JS error 2011-09-06

    I have this error when I try to install Express-on-Railway JS framework, please help: https://github.com/1602/express-on-railway npm ERR! error installing [email protected] Error: Unsupported npm ERR! error installing [email protected] at checkEngine (/u

  • error log trying to install express 2012-01-09

    work with debian testing repositories pointing to testing. I installed node, and express npm following some tutorials and I made some mistakes by not paying attention. 1.- First I did the following as root: https://github.com/joyent/node/wiki/Install

  • Error installing expression web 2 (-2147024873) 2008-12-05

    Anybody ever had the error "Installation of the "Microsoft Expression Web 2" product has reported the following error: -2147024873.. " when trying to install Microsoft Expression Web 2 or Microsoft Expression Studio? This is the error I'm getting, bu

  • Express.js, Node.js Jade - Following the expressjs.com tutorials, and getting errors 2011-05-01

    Well I'm trying to get into Node.js / Express.js - however I've been having a few issue going through the screencast, the first issue, now resolved, was pretty obvious when it was spotted (Express.js, Node.js Jade vim). However, I'm now getting the f

  • Error while installing VS 2013 Express for Windows Desktop 2012-06-25

    Error while installing VS 2013 Express for >>Windows Desktop<< Log File: TinyPaste OS: Windws 8 Enterprise x86 (90 Days Trial) --------------Solutions------------- Hi NH Kom, I appreciate the efforts which you have put to post the query o

  • Can't use kiwi to install express framework 2011-02-20

    Hey guys, I got the same error when I was using kiwi to install stuff, here's the error message I got when I was try to install express framework: Agro:nodesynth Zhulin$ sudo kiwi install express install : express version : create : /Users/Zhulin/.ki

  • installing express on windows issues 2012-01-31

    I am trying to install express framework for node on my Windows system, it always stops with an error: info it worked if it ends with ok verbose cli [ 'C:\Program Files (x86)\nodejs\\node.exe', verbose cli 'C:\Program Files (x86)\nodejs\node_modules\

  • Problems installing express using npm. 2012-04-09

    Im trying to install express using npm, running this code: npm install express mongoose jade less expresso But i keep getting this error, > make deps/jscoverage/node-jscoverage sh: make: command not found npm ERR! [email protected] preinstall: `make

  • Express.js, Node.js Jade vim 2011-04-30

    Help, before I throw my beautiful, expensive MacBook Pro to the ground in a fit of annoyance. I'm trying to get something working in Expressjs, and it's really getting on my nerves. I'm following the tutorial on: expressjs.com/screencasts.html Screen

  • How to install npm when node has been compiled with prefix 2012-02-09

    I have installed node from source using the git repository. The current path of node is /Users/toutpt/makina/cubes/parts/nodejs/bin/node Now I get the source of npm and I can't specify at install tho use this node. Every google results point me out t

  • Error: "expected primary-expression before int" 2012-03-02

    I am getting an error: expected primary-expression before int when I try to return a 2 values in bool function, I think its a member function error. bool binaryTreeTraversal::LeafNode(int node) { return (binaryTreeTraversal::LeftPtr(int node) == NULL

  • Getting gpgkeys host error while installing cookbook of mongodb via Opscode Chef client 2012-04-14

    I am trying to install cookbook of mongodb using opscode chef on ubuntu 10.04 in amzaon Virtual Private Cloud. My error stack is: [Sat, 14 Apr 2012 04:26:00 +0000] INFO: Processing ruby_block[set-env-java-home] action create (java::openjdk line 36) [

  • Cannot install Expressions Studio 4 Web Pro 2012-09-22

    when I try to install expression studio 4 web pro I get an error message that the Net frame is the wrong version but it is the one that it says it is supposed to be. Can anyone help me to get this installed . please! --------------Solutions----------

  • error:expected primary-expression before ',' token //function call 2014-04-09

    I could not figure this out looking at problems with similar errors. I have a node class that was given to me, and I am supposed to implement a sort. I believe I have the sort part working, but I am not sure how to start the linked list in my main. T

  • I keeping getting an error message Outlook Express could not be started. The application was unable to open the Outlook Express message store. (0X8007000E) 2014-08-03

    outlook express 6.0 I keeping getting an error message Outlook Express could not be started. The application was unable to open the Outlook Express message store. Your computer maybe out of memory or your disk is full. Contact Miscrosoft support for

  • error while installing ruby gem 2009-07-16

    I am trying to install a ruby gem. I am getting this error. C:\>gem install racc Building native extensions. This could take a while... ERROR: Error installing racc: ERROR: Failed to build gem native extension. c:/ruby/bin/ruby.exe extconf.rb inst

Copyright (C) dskims.com, All Rights Reserved.

processed in 0.191 (s). 11 q(s)